Author Topic: Exporting TXT With all data does not save to the folder where the file is  (Read 392 times)

unific

  • Newbie
  • *
  • Posts: 5
I'm Trying to export all data to txt with this command
exiftool -a -u -G1 -W+! %f_%e.txt -r D:\Photo
all txt is saved to D:\Photo

When i run this command it works but i want Filename_Ext as filename
exiftool -a -u -G1 -w txt -r

Please can someone help me on the way.

i'm new to Exiftool

Photo are saved
D:\Photo\Year\Month\ Fotoname.jpg




StarGeek

  • Global Moderator
  • ExifTool Freak
  • *****
  • Posts: 3970
You need to add the directory otherwise it will save to the current working directory.  You can use %d to indicate the same directory as the file or explicitly name the directory.

exiftool -a -u -G1 -W+! %d%f_%e.txt -r d:\Photo
will put the txt file in the same directory as the original images.

See the -w (textout) option and the -W option for details.
Troubleshooting hints:
* When posting, include your OS, Exiftool version, and type of file you're processing (MP4, JPG, etc).
* Double all percent signs (%) in a Windows batch file.
* If your GPS coords are negative, make sure and set the GpsLatitudeRef and GpsLongitudeRef tags correctly.

unific

  • Newbie
  • *
  • Posts: 5
You need to add the directory otherwise it will save to the current working directory.  You can use %d to indicate the same directory as the file or explicitly name the directory.

exiftool -a -u -G1 -W+! %d%f_%e.txt -r d:\Photo
will put the txt file in the same directory as the original images.

See the -w (textout) option and the -W option for details.

Thx that did it i was 2 days looking how to do this ..