News:

If this site goes down it is because of the crappy DreamHost web hosting: They will disable your "unlimited traffic" web server if a single bot hammers the site with a moderate load.  If necessary, an alternate ExifTool forum page is available at https://sourceforge.net/p/exiftool/discussion/

Main Menu

Exiftool returns nothing (with ERRORLEVEL -1)

Started by blair, August 19, 2022, 07:10:13 PM

Previous topic - Next topic

blair

Hello, I'm a newbie who has just installed your *awesome* exiftool program. I can drag a JPG file onto the exiftool.exe filename in Explorer and it properly displays the file info -- yay! However, I can't do anything directly from the command line. I copied the executable to C:\Windows\System32, which is in my PATH, and I renamed it to 'exiftool.exe'. I can enter 'exiftool' in the cmd window and Windows doesn't say it can't find it -- so far so good. However, no matter which options I use (for instance, 'exiftool -ver'), the command always just returns to the command prompt without displaying anything, and the ERRORLEVEL is -1.

I'm sure it's me :-) -- What have I done wrong?  Thanks in advance for any help.

StarGeek

* Did you read FAQ #3 and use the command listed there?
* Please use the Code button for exiftool code/output.
 
* Please include your OS, Exiftool version, and type of file you're processing (MP4, JPG, etc).

obetz

Quote from: blair on August 19, 2022, 07:10:13 PMI copied the executable to C:\Windows\System32

don't use the Windows directory or any subdirectory below.

Use a subdirectory in %ProgramFiles% (protected) or %LocalAppData%\Programs\ (not protected). See also https://docs.microsoft.com/en-us/windows/win32/shell/knownfolderid

blair

StarGeek & obetz, thank you for the super-quick replies. I fixed the issue by using Oliver's suggestion to move the executable to %LocalAppData%\Programs. (I also had to add that to my PATH.) Now exiftool works from the cmd window perfectly! Many thanks. :)