Author Topic: charset question / answered  (Read 3564 times)

pedz

  • Newbie
  • *
  • Posts: 1
charset question / answered
« on: May 02, 2010, 01:49:51 PM »
I started out asking a question and then figured it out so thought I'd post what I found.

Using Lightroom 1 on a Mac, I entered keywords with a "LATIN SMALL LETTER E WITH ACUTE".  exiftool was changing this to "LATIN CAPITAL LETTER Z WITH CARON".  I was having trouble getting the -charset with the equals to work for me. 

I was on Image-ExifTool-7.377 and upgraded to Image-ExifTool-8.18.

Anyhow, short story long, Lightroom 1 on a Mac stores the keywords encoded as macroman.  Thus, this solved my problem:

exiftool -charset iptc=macroman -Keywords VC5Y0634.jpg

This same command with 7.377 prints:
Code: [Select]
File not found: iptc=macromanI tried surrounding it with quotes and that did not work either.  In that case, I get:
Code: [Select]
Sorry, charset is not writable
As a side note, there is no IPTC:CodedCharacterSet in the image and there is no way I can see to set it inside Lightroom.

Phil Harvey

  • ExifTool Author
  • Administrator
  • ExifTool Freak
  • *****
  • Posts: 18370
    • ExifTool Home Page
Re: charset question / answered
« Reply #1 on: May 02, 2010, 08:11:02 PM »
Yes, the -charset option is a relatively recent addition.

I know if no utilities which except exiftool which allow writing the IPTC:CodedCharacterSet directly.  Some of them will set it automatically, and many of them will ignore it altogether.

- Phil
...where DIR is the name of a directory/folder containing the images.  On Mac/Linux, use single quotes (') instead of double quotes (") around arguments containing a dollar sign ($).