Author Topic: display of non-standard character in EXIF entry  (Read 1993 times)

Túrelio

  • Newbie
  • *
  • Posts: 2
display of non-standard character in EXIF entry
« on: March 31, 2012, 11:33:43 AM »
Hi,

I would like to have my username (Túrelio) displayed in the EXIF artist and copyright entries of my images, which I release under a CC-BY license at Wikimedia-Commons. I use the most recent ExifTool and ExifToolGUI versions on a Windows XP platform.
Though the name is displayed correctly within ExifToolGUI, when I view the same EXIF entries in other programs, such as IrfanView or XnView, the second character of my username, ú, either is shown wrongly/scrambled or not at all.

I assume this results from the ú not being a standard character, but honestly I couldn’t make sense the "Coded character sets" section in the FAQ. Any easy solution for this problem?

Thanks

Túrelio

BogdanH

  • ExifTool Freak
  • *****
  • Posts: 757
  • ExifToolGUI Author
Re: display of non-standard character in EXIF entry
« Reply #1 on: March 31, 2012, 12:03:06 PM »
Hi Túrelio,

Per specification, non-ASCII characters are not supported in Exif.
If you're using latest ExifToolGUI (v5.nn) then all characters written in Exif (by using Workspace), will be stored in UTF-8 format (see: https://exiftool.org/gui/).

To store characters in ANSI format, then you must use ExifTool direct option. There you write i.e.:
-L -exif:Artist=Túrelio -exif:Copyright="2012 by Túrelio"
..and press Enter key (which executes writing into all selected files).

Another possibility is, to write that info into Xmp metadata section; see:
https://exiftool.org/gui/articles/where_what.html

Bogdan

Túrelio

  • Newbie
  • *
  • Posts: 2
Re: display of non-standard character in EXIF entry
« Reply #2 on: March 31, 2012, 02:15:39 PM »
Hi  Bogdan,

thank you for your kind help and especially for writing the ExifToolGUI.

The ExifTooldirect function did indeed work. However, what's funny, now the ú isn't displayed within ExifTool, which is not a problem, of course.
Before using the xmp section, I will have to study it ;-).

Again, thanks.

Túrelio

BogdanH

  • ExifTool Freak
  • *****
  • Posts: 757
  • ExifToolGUI Author
Re: display of non-standard character in EXIF entry
« Reply #3 on: March 31, 2012, 04:01:32 PM »
Hi,

I'm glad I could help.
If you wish ExifTool to show those characters properly, then use -L option again. For example, select file(s) in GUI, and use:
-L -exif:Artist
..which will show the result in Log window. As you might guess, in Workspace, characters won't be displayed correctly, because here, UTF8 encoded characters are expected.
Anyway, if you plan to use country specific characters for other tags too (i.e. locations, peoples names, etc.), then I believe, Xmp is the best place.

Bogdan