Author Topic: Writing in IDF1 group  (Read 1368 times)

Pleclown

  • Newbie
  • *
  • Posts: 2
Writing in IDF1 group
« on: March 05, 2014, 03:14:27 PM »
I've got a date problem on several images. The camera was off-timed, and I want to correct the files. I've used exiftool -allDate with some results, but not all the dates are corrected.

Those are the results of the commands I tried:

Code: [Select]
pipo@lapin:~/Images/temp/20140305 Salon de l'Auto$ exiftool -G1 -a -s -D DSC02037.ARW | grep Modify
[System]            - FileModifyDate                  : 2014:03:05 20:40:30+01:00
[IFD0]            306 ModifyDate                      : 2014:03:05 08:07:57
[IFD1]            306 ModifyDate                      : 2014:03:05 09:19:57
pipo@lapin:~/Images/temp/20140305 Salon de l'Auto$ exiftool -a "-IDF1:ModifyDate-=1:12" DSC02037.ARW
Warning: Tag 'IDF1:ModifyDate' does not exist
Nothing to do.

Is there something I'm not doing right ?

Phil Harvey

  • ExifTool Author
  • Administrator
  • ExifTool Freak
  • *****
  • Posts: 16906
    • ExifTool Home Page
Re: Writing in IDF1 group
« Reply #1 on: March 06, 2014, 05:18:57 AM »
It's just a simple typo:  You meant "IFD1", not "IDF1".

- Phil
...where DIR is the name of a directory/folder containing the images.  On Mac/Linux, use single quotes (') instead of double quotes (") around arguments containing a dollar sign ($).

Pleclown

  • Newbie
  • *
  • Posts: 2
Re: Writing in IDF1 group
« Reply #2 on: March 06, 2014, 01:15:51 PM »
Ok, I'm officially ashamed...