News:

If this site goes down it is because of the crappy DreamHost web hosting: They will disable your "unlimited traffic" web server if a single bot hammers the site with a moderate load.  If necessary, an alternate ExifTool forum page is available at https://sourceforge.net/p/exiftool/discussion/

Main Menu

I can't rename using -filename<CreateDate - SOLVED

Started by Daniel L S, March 07, 2016, 05:17:15 PM

Previous topic - Next topic

Daniel L S

I try rename filenames to "date time" by:
exiftool -d %Y%m%d_%H%M%%-c.%%e "-filename<CreateDate" -ext jpg *

When I run in folder with this files: DSC04921.JPG, DSC04926.JPG, DSC04927.JPG
I end up with this file: mHe, DSC04926.JPG, DSC04927.JPG
It seams problem with date?

if I run: exiftool -a -G1 -s -time:all -ext jpg *
CreateDate looks fine, it shows [ExifIFD] CrateDate: 2015:01:09 14:25:33

I use "Windows Executable: exiftool-10.12.zip (5.0 MB)" on Win7



StarGeek

Is it in a batch file?  If so, all percent signs need to be doubled:
exiftool -d %%Y%%m%%d_%%H%%M%%%%-c.%%%%e "-filename<CreateDate" -ext jpg *
* Did you read FAQ #3 and use the command listed there?
* Please use the Code button for exiftool code/output.
 
* Please include your OS, Exiftool version, and type of file you're processing (MP4, JPG, etc).

Daniel L S

SOLVED - THANK YOU!!!!
You been to very big help for me!
I have spent hours searching try to read and find out what was wrong!!!!   ;D ;D ;D ;D
I very happy!!! Big thank you!!!!  ::) 8) ;D ;D