Author Topic: CSV -> .mov metadata export: getting rid of " "  (Read 869 times)

JustDrive

  • Newbie
  • *
  • Posts: 3
CSV -> .mov metadata export: getting rid of " "
« on: March 29, 2017, 08:07:56 AM »
Hey, a forum and an ExifTool newbie here :)

I want to use the tool to extract metadata from a .csv list and apply the values to a set of .mov files. I've succesfully managed to extract the values for Description and Keywords (IPTC categories in Bridge, had to rename the "Keywords" to Subject in the .csv for the export to work) and apply them to .mov files, however the keywords have a quotation mark " added to the beginning and end of each string (so for example where in the .csv file under Subject I have keyword1, keyword2 I now have "keyword1, keyword2" when looking at the .mov files Keywords metadata in Adobe Bridge.

Is there any way to get rid of the quotation marks when exporting?

Thank you very much in advance!

StarGeek

  • Global Moderator
  • ExifTool Freak
  • *****
  • Posts: 3803
Re: CSV -> .mov metadata export: getting rid of " "
« Reply #1 on: March 29, 2017, 10:34:13 AM »
Quick answer: Try adding -sep "," to the command that you use to write the data.

If I understand you correctly, you are adding your keywords to your files using exiftool, then checking the data with Bridge?  If that's the case, then what is happening is the keywords are added to the file as a single string.  So you have a single keyword like this:
keyword1, keyword2
not separate keywords like this:
keyword1
keyword2

I believe Bridge will normally separate keywords with a comma when it shows it to you, but since there is a comma in the keyword, it puts quotes around it to show you what's happening.  They don't actually exist in the data.

Adding the -sep option above will tell exiftool to separate the keywords properly.
Troubleshooting hints:
* When posting, include your OS, Exiftool version, and type of file you're processing (MP4, JPG, etc).
* Double all percent signs (%) in a Windows batch file.
* If your GPS coords are negative, make sure and set the GpsLatitudeRef and GpsLongitudeRef tags correctly.

JustDrive

  • Newbie
  • *
  • Posts: 3
Re: CSV -> .mov metadata export: getting rid of " "
« Reply #2 on: March 29, 2017, 03:16:37 PM »
That did the trick, thanks a lot for the help.