Author Topic: Regression: exiftool cannot embed into AI when output file specified.  (Read 989 times)

onagornyi

  • Newbie
  • *
  • Posts: 1
Hello,
found that exiftool cannot embed into AI when output file specified.
Embed into AI works only if output option point to the folder or not specified at all.

OS: macosx 10.11
Exiftool: 10.79
Commandline: exiftool -n -m -E -description=TestDesctiption -o test2.ai test1.ai
Output:
Code: [Select]
Error: Can't create AI file from PDF - test1.ai
    0 image files updated
    1 files weren't updated due to errors
Same command line works fine in exiftool 10.15 but staring from 10.16 till now doesn't.

Thanks,

Olexandr

Phil Harvey

  • ExifTool Author
  • Administrator
  • ExifTool Freak
  • *****
  • Posts: 18006
    • ExifTool Home Page
Re: Regression: exiftool cannot embed into AI when output file specified.
« Reply #1 on: February 26, 2018, 07:52:13 AM »
Hi Olexandr,

Thanks for this report.  This will be fixed for ExifTool 10.81

- Phil
...where DIR is the name of a directory/folder containing the images.  On Mac/Linux, use single quotes (') instead of double quotes (") around arguments containing a dollar sign ($).

Phil Harvey

  • ExifTool Author
  • Administrator
  • ExifTool Freak
  • *****
  • Posts: 18006
    • ExifTool Home Page
Re: Regression: exiftool cannot embed into AI when output file specified.
« Reply #2 on: February 26, 2018, 10:08:41 AM »
Version 10.81 is now available.
...where DIR is the name of a directory/folder containing the images.  On Mac/Linux, use single quotes (') instead of double quotes (") around arguments containing a dollar sign ($).