ExifTool Forum

ExifTool => Newbies => Topic started by: rwells1938 on July 02, 2012, 08:13:31 AM

Title: Exiftool hangs?
Post by: rwells1938 on July 02, 2012, 08:13:31 AM
When I run the following script it will sometimes hang trying to find apath. It always works the first time but if run again it hangs. If I cancel and retry it will most of the time work fine but maybe the next time it will hang again.

Any suggestions?
Mac osx 10.7.4

- select image
set aPath to quoted form of POSIX path of (choose file)

-- Display path
display dialog aPath

-- Get Metadata
set aScript to "exiftool  -CreateDate -Modifydate -FileModifyDate -MetadataDate " & aPath

-- save result
set aResult to do shell script aScript
Title: Re: Exiftool hangs?
Post by: Phil Harvey on July 03, 2012, 07:34:30 AM
I think this is a question for an AppleScript forum.

Just for fun, I tried your script and it did hang once in the file selection dialog, but then worked every time after that.  I can't think of what the problem could be.

- Phil