Author Topic: Rename Commmand for MOV suddenly not working  (Read 621 times)

fod

  • Newbie
  • *
  • Posts: 4
Rename Commmand for MOV suddenly not working
« on: July 20, 2019, 08:44:56 PM »
Good Day,
I've been using Exiftool to manage (tag and rename) my vast photo and video library for quite some time. Let me preface this by admitting that I am novice at best user of this outstanding Exiftool. Anyway, to the problem. I have been using the following command to rename mov files taken with our various apple devices:

exiftool '-FileName<CreateDate' -ext MOV -d '%Y-%m-%d--%H.%M.%S.MOV' .

The workflow is as follows. I import the videos from the iPhone using Image Capture and then run the above command to rename the file to the create date.

This has been working great for years. Yesterday I noticed that the video files from our iPhoneXMax do not correctly rename. Rather than taking the createdate, it is simply renaming to the current date. I have in the past (Feb 2019) renamed video from this device correctly. I updated Exiftool and tried again. Still same problem. Any ideas how I can get back on track renaming my iPhone X videos to the createdate?

Thank you in advance,

Fod

Hayo Baan

  • Global Moderator
  • ExifTool Freak
  • *****
  • Posts: 1140
  • Professional Photographer & Software Developer
    • Hayo Baan – Photography
Re: Rename Commmand for MOV suddenly not working
« Reply #1 on: July 21, 2019, 03:13:11 AM »
What does exiftool -a -g0:1 -createdate MOV tell you (replace MOV with one of the movie files)?
Hayo Baan – Photography
Web: www.hayobaan.nl

fod

  • Newbie
  • *
  • Posts: 4
Re: Rename Commmand for MOV suddenly not working
« Reply #2 on: July 21, 2019, 04:50:37 AM »
IMG_0025.MOV
---- QuickTime ----
Create Date                     : 2019:07:21 02:09:48

this is the result. Yet when I use the getinfo function in apple finder/Preview. it shows the create date and modify date as the date the video was taken.

My guess is that the problem could be related to Image Capture needing to reformat Apple IOS' new high efficiency video format into .MOV on import. For some reason one of MacOS's last updates must have changed something in the way createdate tag is recognized by Exiftool. .mov from my iphone 6 work fine. only .mov from iphone max x aren't working suddenly. I'm not nearly competent enough to track this down. Hopefully someone here might have an idea to send me in the right direction in order to recover my workflow.

Thanks,

FOD

fod

  • Newbie
  • *
  • Posts: 4
Re: Rename Commmand for MOV suddenly not working
« Reply #3 on: July 21, 2019, 05:04:53 AM »
hmmm. seems i've sorted it, kind of. Looks like the tag reference has changed. So createdate and modifydate return the date of encoding by Image Capture. filemodifydate and filecreatedate return the date of original recording. So simple syntax change will sort my troubles out. Thank you Hayo Baan, your question set me in the right direction.

Fod

Hayo Baan

  • Global Moderator
  • ExifTool Freak
  • *****
  • Posts: 1140
  • Professional Photographer & Software Developer
    • Hayo Baan – Photography
Re: Rename Commmand for MOV suddenly not working
« Reply #4 on: July 21, 2019, 06:11:00 AM »
hmmm. seems i've sorted it, kind of. Looks like the tag reference has changed. So createdate and modifydate return the date of encoding by Image Capture. filemodifydate and filecreatedate return the date of original recording. So simple syntax change will sort my troubles out. Thank you Hayo Baan, your question set me in the right direction.

Hmm indeed, filemodifydate and filecreatedate are non-stable since they will/might change when the file is modified. It's unfortunate that when exporting the HEIC MOV to e.g. QT, it changes the QT CreateDate to when it converted the file. I guess the reasoning is that that's the time when the new file is created, but that is really not what you want (ModifyDate, yes, that one I can see would be updated). You actually triggered me to have a look at my own movie files (I don't have many) and indeed, the ones I edited/converted got the wrong date info.

To be sure you don't actually lose the real dates, I suggest you update the CreateDate to reflect the “real” creation date.
Hayo Baan – Photography
Web: www.hayobaan.nl

fod

  • Newbie
  • *
  • Posts: 4
Re: Rename Commmand for MOV suddenly not working
« Reply #5 on: July 21, 2019, 06:17:34 AM »
Top tip. I will change the createdate to reflect the original recording! Thanks again!

FOD

Alan Clifford

  • ExifTool Freak
  • *****
  • Posts: 469
    • A selection of Alan Clifford's photographs
Re: Rename Commmand for MOV suddenly not working
« Reply #6 on: July 21, 2019, 06:36:58 AM »
Are there any other dates in there that could be used?

exiftool -G -a  -*date* file.mov