Author Topic: Attempting to copy EXIF data from Sigma x3f to a DNG. Not working.  (Read 202 times)

simonlucas

  • Newbie
  • *
  • Posts: 5
From a thread in dpreview I found a way to a copy EXIF data from x3f file to an DNG made by x3f_tool (v057).

https://www.dpreview.com/forums/post/56730961

(NB. I am using the DNGs made by the x3f_tool, rather than the native camera DNGs for good reason)


$ exiftool -TagsFromFile srcimage.x3f "-all:all>all:all" targetimage.dng

But I get this error:

> Warning: No writable tags set from SDIMXXXX.x3f

Then using

$ exiftool SDIMXXXX.x3f

I get no useful-looking EXIF camera data from the original x3f (see below).  I do not know whether this is why I get the warning quoted above.

Is this the problem with the files, the exiftool, or the copy command? And how can I fix it, please?

Thank-you.

-------

OUTPUT:

ExifTool Version Number : 11.99
File Name : SDIMXXXX.x3f
Directory : .
File Size : 58 MB
File Modification Date/Time : 2020:06:05 17:27:40+01:00
File Access Date/Time : 2020:06:06 12:06:01+01:00
File Inode Change Date/Time : 2020:06:05 18:50:21+01:00
File Permissions : rwxrwxrwx
File Type : X3F
File Type Extension : x3f
MIME Type : image/x-sigma-x3f
File Version : 4.1
Image Width : 5424
Image Height : 3616
Rotation : 90
Preview Image : (Binary data 11190252 bytes, use -b option to extract)
Image Size : 5424x3616
Megapixels : 19.6

StarGeek

  • Global Moderator
  • ExifTool Freak
  • *****
  • Posts: 3795
Re: Attempting to copy EXIF data from Sigma x3f to a DNG. Not working.
« Reply #1 on: June 06, 2020, 11:08:01 AM »
From the look of that output, there isn't any EXIF data.

Run this command on the file
exiftool -G1 -a -s -EXIF:all SDIMXXXX.x3f

That will show only the EXIF data and not other things like FILE or COMPOSITE groups.
Troubleshooting hints:
* When posting, include your OS, Exiftool version, and type of file you're processing (MP4, JPG, etc).
* Double all percent signs (%) in a Windows batch file.
* If your GPS coords are negative, make sure and set the GpsLatitudeRef and GpsLongitudeRef tags correctly.

simonlucas

  • Newbie
  • *
  • Posts: 5
Re: Attempting to copy EXIF data from Sigma x3f to a DNG. Not working.
« Reply #2 on: June 06, 2020, 01:53:48 PM »
From the look of that output, there isn't any EXIF data.

Run this command on the file
exiftool -G1 -a -s -EXIF:all SDIMXXXX.x3f

That will show only the EXIF data and not other things like FILE or COMPOSITE groups.

I ran this and got nothing. Not even an error.

If I run it on the in-camera jpg - made at the same time as the x3f,  then I get a full EXIF output.

I should mention that I am working on MacOS 10.13.6.
« Last Edit: June 06, 2020, 02:30:19 PM by simonlucas »

StarGeek

  • Global Moderator
  • ExifTool Freak
  • *****
  • Posts: 3795
Re: Attempting to copy EXIF data from Sigma x3f to a DNG. Not working.
« Reply #3 on: June 06, 2020, 02:59:46 PM »
I ran this and got nothing. Not even an error.

Then there is no EXIF data in the file.
Troubleshooting hints:
* When posting, include your OS, Exiftool version, and type of file you're processing (MP4, JPG, etc).
* Double all percent signs (%) in a Windows batch file.
* If your GPS coords are negative, make sure and set the GpsLatitudeRef and GpsLongitudeRef tags correctly.

simonlucas

  • Newbie
  • *
  • Posts: 5
Re: Attempting to copy EXIF data from Sigma x3f to a DNG. Not working.
« Reply #4 on: June 06, 2020, 04:28:50 PM »
I ran this and got nothing. Not even an error.

Then there is no EXIF data in the file.

Ok. I'm not sure how that is possible as it's straight off my camera, but I'll ask the Sigma forum.

Thank-you for your help!

simonlucas

  • Newbie
  • *
  • Posts: 5
Re: Attempting to copy EXIF data from Sigma x3f to a DNG. Not working.
« Reply #5 on: June 06, 2020, 05:09:36 PM »
I just wonder is it possible that exiftool is not working with x3f files on my mac?

This is the data that Sigma PhotoPro 6 shows for one of the files


simonlucas

  • Newbie
  • *
  • Posts: 5
Re: Attempting to copy EXIF data from Sigma x3f to a DNG. Not working.
« Reply #6 on: June 06, 2020, 05:23:09 PM »
Ok. I tested a smple x3f that i downloaded. It works in the exiftool. So something weird about the files from my camera. Thank-you for your help with this.

Phil Harvey

  • ExifTool Author
  • Administrator
  • ExifTool Freak
  • *****
  • Posts: 16706
    • ExifTool Home Page
Re: Attempting to copy EXIF data from Sigma x3f to a DNG. Not working.
« Reply #7 on: June 07, 2020, 08:54:28 PM »
Can you send me one of the files from your camera so I can take a look (philharvey66 at gmail.com)?

- Phil
...where DIR is the name of a directory/folder containing the images.  On Mac/Linux, use single quotes (') instead of double quotes (") around arguments containing a dollar sign ($).

Phil Harvey

  • ExifTool Author
  • Administrator
  • ExifTool Freak
  • *****
  • Posts: 16706
    • ExifTool Home Page
Re: Attempting to copy EXIF data from Sigma x3f to a DNG. Not working.
« Reply #8 on: June 28, 2020, 12:57:27 PM »
ExifTool version 12.00 (released June 11) adds support for extracting metadata from DP2Q X3F files.

- Phil
...where DIR is the name of a directory/folder containing the images.  On Mac/Linux, use single quotes (') instead of double quotes (") around arguments containing a dollar sign ($).