Author Topic: Problem reading xmp sidecar files created by ImageIngester Pro  (Read 2747 times)

Louie Sherwin

  • Newbie
  • *
  • Posts: 6
I use ImageIngester Pro to import my raw files and to assign bulk metadata. This creates an .xmp sidecar file for each raw file. Until recently I have immediately converted to dng format before further processing with Bridge and Photoshop (CS4). This has always worked with out any problems.

For a number of reasons I have decided not to convert to dng until maybe later in my workflow. I am planing to use exiftool to transfer all the current metadata  for each image from the dng back to the xmp sidecar. Since all the image files have the same root file name this should be fairly straight forward.

However, when I tried to use exiftool to examint the xmp sidecar files produced by IIP I get the following error.

% exiftool -G1 -s sherwin_20081211_0051.xmp
Code: [Select]
[ExifTool]      ExifToolVersion                 : 8.18
[ExifTool]      Error                           : File format error
[System]        FileName                        : sherwin_20081211_0051.xmp
[System]        Directory                       : .
[System]        FileSize                        : 4.0 kB
[System]        FileModifyDate                  : 2008:12:11 21:53:52-08:00
[System]        FilePermissions                 : rw-r--r--

Interestingly if I make any change to the metadata in Bridge or Lightroom exiftool will recognize the file just fine.

I have attached one of the xmp sidecar files that is causing this error.

tks, louie
MacOS 10.5.8, IIP 3, Lightroom 3b2, Photoshop CS4

Louie Sherwin

  • Newbie
  • *
  • Posts: 6
Re: Problem reading xmp sidecar files created by ImageIngester Pro
« Reply #1 on: April 27, 2010, 10:32:00 PM »
I noticed that there is a blank line at the beginning of the problem xmp files and when I edit and remove this blank line exiftool works without reporting the format error.

I don't know if this is contrary to the xmp specification but since Lightroom and Bridge don't have a problem it seems reasonable that exiftool would be able to ignore one or more blank lines also. If it is not according to the specification I will report it as a bug to the IIP developer.

In the mean time I have 8000+ raw files with xmp sidecars that have a initial blank line and it would be extremely helpful if exiftool could be made to handle this situation.

tks, louie
MacOS 10.5.8, IIP 3, Lightroom 3b2, Photoshop CS4

Phil Harvey

  • ExifTool Author
  • Administrator
  • ExifTool Freak
  • *****
  • Posts: 17018
    • ExifTool Home Page
Re: Problem reading xmp sidecar files created by ImageIngester Pro
« Reply #2 on: April 28, 2010, 07:06:02 AM »
Hi Louie,

Thanks for reporting this.  The next exiftool release (8.19) will be able to handle these XMP files.

- Phil
...where DIR is the name of a directory/folder containing the images.  On Mac/Linux, use single quotes (') instead of double quotes (") around arguments containing a dollar sign ($).