Author Topic: LargeFileSupport not enabled  (Read 19721 times)

beroe

  • Newbie
  • *
  • Posts: 5
Re: LargeFileSupport not enabled
« Reply #15 on: April 13, 2015, 09:22:17 PM »
I have 9.0.2. I'll try again after updating and see how things look.

Thanks again.

Not sure where to host a 6GB file, but I can try temporarily putting it on a local ftp and e-mail a link to you.

beroe

  • Newbie
  • *
  • Posts: 5
Re: LargeFileSupport not enabled
« Reply #16 on: April 13, 2015, 09:56:47 PM »
I upgraded to 9.92 and .. IT WORKS!

Thanks. Sorry about that rookie mistake -- I was originally on a ship when I was testing and never checked for updates when I got back.




NMAAHC

  • Newbie
  • *
  • Posts: 6
Re: LargeFileSupport not enabled
« Reply #17 on: February 19, 2016, 03:39:22 PM »
Hi,

I'm having the same issue with
Code: [Select]
"Warning : End of processing at large atom (LargeFileSupport not enabled)"
I'm looking for my exiftool config file in my home directory but ls -a isn't listing anything that it could be.

Do I have to create one first?

Thanks,
Bleakley

Phil Harvey

  • ExifTool Author
  • Administrator
  • ExifTool Freak
  • *****
  • Posts: 16878
    • ExifTool Home Page
Re: LargeFileSupport not enabled
« Reply #18 on: February 19, 2016, 03:51:25 PM »
Hi Bleakley,

Yes, you need to create it.  Check out the sample config file and example.

- Phil
...where DIR is the name of a directory/folder containing the images.  On Mac/Linux, use single quotes (') instead of double quotes (") around arguments containing a dollar sign ($).

k_grons

  • Newbie
  • *
  • Posts: 5
Re: LargeFileSupport not enabled
« Reply #19 on: March 16, 2016, 09:53:56 AM »
Hi,

- I updated my ExifTool version to 10.13.
- I verified that my config file exists in /usr/local/bin and includes:
Code: [Select]
%Image::ExifTool::UserDefined::Options = (
    LargeFileSupport => 1,
);
1; #end

When I run:
Code: [Select]
$ exiftool <.mov file over 100 GB>
I get the error
Code: [Select]
Warning                         : End of processing at large atom (LargeFileSupport not enabled)

Any idea what the issue may be?

Hayo Baan

  • Global Moderator
  • ExifTool Freak
  • *****
  • Posts: 1140
  • Professional Photographer & Software Developer
    • Hayo Baan – Photography
Re: LargeFileSupport not enabled
« Reply #20 on: March 16, 2016, 11:14:01 AM »
You config file should be in your user's home directory, not in bin!
Hayo Baan – Photography
Web: www.hayobaan.nl

k_grons

  • Newbie
  • *
  • Posts: 5
Re: LargeFileSupport not enabled
« Reply #21 on: March 16, 2016, 12:45:46 PM »
Hi Hayo,

Thanks! I moved .ExifTool_config to my home directory, but still getting the same error:

Code: [Select]
Warning                         : End of processing at large atom (LargeFileSupport not enabled)
I installed ExifTool using the Mac installer, and it's in /usr/local/bin - could that be the issue?

Thanks again.

Phil Harvey

  • ExifTool Author
  • Administrator
  • ExifTool Freak
  • *****
  • Posts: 16878
    • ExifTool Home Page
Re: LargeFileSupport not enabled
« Reply #22 on: March 16, 2016, 02:25:13 PM »
The config file should work in your home directory.  FAQ 11 has some tips for helping with config file problems.

- Phil
...where DIR is the name of a directory/folder containing the images.  On Mac/Linux, use single quotes (') instead of double quotes (") around arguments containing a dollar sign ($).

k_grons

  • Newbie
  • *
  • Posts: 5
Re: LargeFileSupport not enabled
« Reply #23 on: March 17, 2016, 01:08:32 PM »
Phil,

Thank you - I was able to solve the issue using the troubleshooting procedures described in FAQ 11.

Thanks!

Phil Harvey

  • ExifTool Author
  • Administrator
  • ExifTool Freak
  • *****
  • Posts: 16878
    • ExifTool Home Page
Re: LargeFileSupport not enabled
« Reply #24 on: March 17, 2016, 01:10:00 PM »
So, what was the problem?
...where DIR is the name of a directory/folder containing the images.  On Mac/Linux, use single quotes (') instead of double quotes (") around arguments containing a dollar sign ($).

Harald

  • Full Member
  • ***
  • Posts: 39
Re: LargeFileSupport not enabled
« Reply #25 on: October 05, 2016, 07:25:57 AM »
Hi Phil,
I have the same problem of getting the error message "End of processing at large atom (LargeFileSupport not enabled)". I have added the entry "%Image::ExifTool::UserDefined::Options = (
    LargeFileSupport => 1,
);"
in my config file as you advised. I have also performed the test with "Writing XMP-xmp:NewXMPxmpTag" and could see that tag, so obviously my config-file is recognised. But nonetheless the error message persists.I attach the file for your convenience.

I have to meta tag a large amount of videos, many of which are above 4GB and I use the Windows software TagScanner to add the metadata - which is actually tags that I designed myself. I can verify that they exist for small files, but not for the one that exceed the critical file size.
Can you help out?

On a personal note: I used to windsurf a lot when I was young and my fathers company made the booms and masts for many companies. The one you are using in your profile picture might actually have come out of our workshop :)
I attach a pic of myself (Loongtime ago) for your entertainment :)

Phil Harvey

  • ExifTool Author
  • Administrator
  • ExifTool Freak
  • *****
  • Posts: 16878
    • ExifTool Home Page
Re: LargeFileSupport not enabled
« Reply #26 on: October 05, 2016, 07:42:15 AM »
Nice duck gybe with that polyester clark-foam board!  Looks like Hatteras.  I've got lots of picture of myself that are very similar. :)  I need some replacement masts though, so if you have any constant-curve 25-75% carbon 25 DIN standard-diameter 4.65m masts around, let me know.

The problem with your config file is that %Image::ExifTool::UserDefined::Options is defined twice, and the one at the bottom of the file is overriding your definition.

- Phil


...where DIR is the name of a directory/folder containing the images.  On Mac/Linux, use single quotes (') instead of double quotes (") around arguments containing a dollar sign ($).

Harald

  • Full Member
  • ***
  • Posts: 39
Re: LargeFileSupport not enabled
« Reply #27 on: October 06, 2016, 10:19:19 AM »
Hi Phil,

SUPER COOL! That was it and it works like a charm now.  :-*
By the way: we have recently bought the UK based DAM Assetbank. You might be interested to hear that in the backend they use your tool to read and write metadata. I guess this is in line with your license or you get a revenue from it.

Regarding the mast: unfortunately the company had to stop producing windsurfing equipment 20 years ago when the mountain bikes wiped out the windsurfing market. :(
But anyway, we were only making aluminium masts. I can imagine it is hard to get equipment nowadays.  Assuming that you are in the states and I am in Europe, shipping would have been an issue :)
Thanks a lot for your help again. There might be the one or other question upcoming as we have the huge task of migrating 80.000 pictures from two organisations into the DAM. Very much appreciated to see you are as responsive as your tool is amazing.

- Harald

Phil Harvey

  • ExifTool Author
  • Administrator
  • ExifTool Freak
  • *****
  • Posts: 16878
    • ExifTool Home Page
Re: LargeFileSupport not enabled
« Reply #28 on: October 06, 2016, 10:53:45 AM »
Hi Harald,

You might be interested to hear that in the backend they use your tool to read and write metadata. I guess this is in line with your license or you get a revenue from it.

ExifTool is free.  Donations are all voluntary, even for commercial use.

Quote
unfortunately the company had to stop producing windsurfing equipment 20 years ago when the mountain bikes wiped out the windsurfing market. :(

Yup...  Windsurfing has had its day I guess.  I should have bought more masts back when I could. :P

Quote
There might be the one or other question upcoming as we have the huge task of migrating 80.000 pictures from two organisations into the DAM.

ExifTool should be up to the task.  One ExifTool client I know has run it on 30.000.000.000 images (without any donations I might add).

- Phil
...where DIR is the name of a directory/folder containing the images.  On Mac/Linux, use single quotes (') instead of double quotes (") around arguments containing a dollar sign ($).

Harald

  • Full Member
  • ***
  • Posts: 39
Re: LargeFileSupport not enabled
« Reply #29 on: October 17, 2016, 06:47:38 AM »
Hi Phil,
yes, everything that arises comes to an end.  That is even true for Windsurfing :)
Quite clever, those Buddhists :)

I consider your making Exiftool available for free even for commercial use to be incredibly generous and I rejoice ins this great attitude. Very inspiring! Thank you for this great example in a time of incredible greed!
 :D
I have progressed with the project and have added extra meta tags to our videos (.mp4) to ingest them into the DAM. I used the Windows Software TagScanner not to have to dive into the seemingly complex task of defining them in the config file.

When I use Exiftool to list the tag it works fine. For example:
------------------------------------------------------------------------------------------------------------------------
FPMTMBP:Desktop FPMTmrm$ exiftool -youtubelink /Users/FPMTmrm/Desktop/20100923_2000_LZR_LOP.mp4
YOUTUBE LINK                    : https://www.youtube.com/watch?v=Qgas5fmDry4
------------------------------------------------------------------------------------------------------------------------

But when I try to write to the same file:
------------------------------------------------------------------------------------------------------------------------
FPMTMBP:Desktop FPMTmrm$ exiftool -youtubelink='www.youtube.com' /Users/FPMTmrm/Desktop/20100923_2000_LZR_LOP.mp4
Warning: Tag 'youtubelink' does not exist
Nothing to do.
------------------------------------------------------------------------------------------------------------------------

Any idea why Exiftool recognises the metatag when listing, but not for writing?
In case needed, I uploaded the video here:
https://fpmt.box.com/s/11wowk6o8j0d37ur62ycskk95bxk5xjv
I had to share this link via email to grant you access. Sorry for the bother!

Thanks a lot in advance for your help! Have a great week!
kind regards,
Harald

_____________________________