Author Topic: LargeFileSupport not enabled  (Read 19707 times)

Phil Harvey

  • ExifTool Author
  • Administrator
  • ExifTool Freak
  • *****
  • Posts: 16877
    • ExifTool Home Page
Re: LargeFileSupport not enabled
« Reply #30 on: October 17, 2016, 08:08:49 AM »
Hi Harald,

ExifTool has only limited write ability for MP4 videos.  See the QuickTime tags documentation for details.

- Phil
...where DIR is the name of a directory/folder containing the images.  On Mac/Linux, use single quotes (') instead of double quotes (") around arguments containing a dollar sign ($).

Harald

  • Full Member
  • ***
  • Posts: 39
Re: LargeFileSupport not enabled
« Reply #31 on: October 17, 2016, 10:11:58 AM »
Hi Phil,
thanks for the quick reply.
Unfortunate for us that Exiftool is not able to change tags outside the QuickTime specification. I will have to try using TagScanner with an Excel file.
Maybe worthwhile altering the error message from "tag xxxx does not exist" to "not supported" or similar.

In any case, thanks for your help. Exiftool will still be very helpful for our images.

kind regards,
Harald

_____________________________


Phil Harvey

  • ExifTool Author
  • Administrator
  • ExifTool Freak
  • *****
  • Posts: 16877
    • ExifTool Home Page
Re: LargeFileSupport not enabled
« Reply #32 on: October 17, 2016, 11:35:40 AM »
Hi Harald,

Maybe worthwhile altering the error message from "tag xxxx does not exist" to "not supported" or similar.

I see your point.  It does not exist in ExifTool's database, but it is confusing if you were thinking it meant in your file.

I'll have to think about this though.  Changing the wording of messages isn't something I take lightly because doing so may break some scripts that use ExifTool.

- Phil
...where DIR is the name of a directory/folder containing the images.  On Mac/Linux, use single quotes (') instead of double quotes (") around arguments containing a dollar sign ($).

Harald

  • Full Member
  • ***
  • Posts: 39
Re: LargeFileSupport not enabled
« Reply #33 on: October 21, 2016, 04:40:33 AM »
Hi Phil,
Quote
Changing the wording of messages isn't something I take lightly because doing so may break some scripts that use ExifTool.
I see. There is always implications that one does not see from outside.

A completely different question: I notice you support reading tags of Word files, but when I try to write to a .docx file it says
Quote
Error: Writing of DOCX files is not yet supported
Do you plan to add this any time soon? We need to put the current file path on the local drive to the metadata before ingesting to the DAM and I wonder how to do that.
Thanks a lot in advance for your help.
kind regards,
Harald

_____________________________

Phil Harvey

  • ExifTool Author
  • Administrator
  • ExifTool Freak
  • *****
  • Posts: 16877
    • ExifTool Home Page
Re: LargeFileSupport not enabled
« Reply #34 on: October 21, 2016, 07:16:12 AM »
First, I've considered your "TAG not supported" suggestion and will implement this in the next release.

Second, support for DOCX is not going to happen soon.  ExifTool would have to support writing ZIP files as well as arbitrary XML to be able to do this.

- Phil
...where DIR is the name of a directory/folder containing the images.  On Mac/Linux, use single quotes (') instead of double quotes (") around arguments containing a dollar sign ($).

Harald

  • Full Member
  • ***
  • Posts: 39
Re: LargeFileSupport not enabled
« Reply #35 on: October 21, 2016, 08:38:15 AM »
Hi Phil,

thanks a lot for the quick response. Too bad, but to be expected.
And I guess, you are not aware of any tool that would be suitable to write metadata to .doc files in batch, e. g. from a CSV file?
kind regards,
Harald

_____________________________

Phil Harvey

  • ExifTool Author
  • Administrator
  • ExifTool Freak
  • *****
  • Posts: 16877
    • ExifTool Home Page
Re: LargeFileSupport not enabled
« Reply #36 on: October 21, 2016, 08:43:01 AM »
Hi Harald,

Sorry, I don't know of any such tools.

- Phil
...where DIR is the name of a directory/folder containing the images.  On Mac/Linux, use single quotes (') instead of double quotes (") around arguments containing a dollar sign ($).

Harald

  • Full Member
  • ***
  • Posts: 39
Re: LargeFileSupport not enabled
« Reply #37 on: October 21, 2016, 09:04:48 AM »
Hi Phil,
I just realised that there might have been a misunderstanding regarding the MP4 files. You wrote
Quote
ExifTool has only limited write ability for MP4 videos.  See the QuickTime tags documentation for details.

Yet I found that I can successfully write Country and City to a video with Exiftool, both not being QuickTime tags, right? At least I could not find "City" in the link you provided.
Actually it even created new entries for Country. I had added a COUNTRY-tag with Mp3tag, but when I reset the tag with Exiftool it showed up with small letters and listing them with "Exiftool -country" would result in
-COUNTRY: Untited States  -> from MP3tag
-Country: India                  -> from Exiftool

So it had left the one from MP3tag alone and written to its own specification.
All our videos in question are H264 .mp4 videos, usually encoded with handbrake or Adobe Premiere Media Encoder. As far as I understand, these are not QuickTime videos, correct?

Yet when I look at the embedded metadata of an asset that I had ingested into Assetbank - which uses Exiftool at the backend - all tags show up as QuickTime:...., even City, Country and Youtube link, where at least the last one is obviously not an official tag.

I assume either
a) these are actually XMP tags that are listed incorrectly in Assetbank or
b) it is possible to write extra QuickTime tags but you chose not to implement this in Exiftool.

Please let me know whether I am wrong and if it is indeed possible to extend XMP-tags and write to them, how I could achieve this.
Sorry for bothering you that much.

best regards,
Harald

Phil Harvey

  • ExifTool Author
  • Administrator
  • ExifTool Freak
  • *****
  • Posts: 16877
    • ExifTool Home Page
Re: LargeFileSupport not enabled
« Reply #38 on: October 21, 2016, 09:23:09 AM »
Hi Harald,

ExifTool can write XMP to MP4 files.  The Country tag you wrote must be XMP.

I can't speak for Assetbank, but you should see this in XMP if you read it back again using ExifTool with the -G option.

- Phil
...where DIR is the name of a directory/folder containing the images.  On Mac/Linux, use single quotes (') instead of double quotes (") around arguments containing a dollar sign ($).

Harald

  • Full Member
  • ***
  • Posts: 39
Re: LargeFileSupport not enabled
« Reply #39 on: October 21, 2016, 01:32:06 PM »
Hi Phil,

thanks, the -G option helped me a lot and clarified the whereabouts for many tags. Thanks for all your help.

kind regards,
Harald

_____________________________

gheppell

  • Jr. Member
  • **
  • Posts: 17
Re: LargeFileSupport not enabled
« Reply #40 on: February 17, 2020, 02:40:15 PM »
Pardon my technological ignorance, but i am trying to get around the largefillesupport enabled issue, but am confused.  I note that you point to a config file as a workaround.  However, I do not know how or where to enable such a file.  Is this a text file?  Where do I put the file within my directories (Win 10)?  Should I be typing something at a command line?  If possible, I need step by step instructions as to how to get around the largefile issue.

thank you

StarGeek

  • Global Moderator
  • ExifTool Freak
  • *****
  • Posts: 3948
Re: LargeFileSupport not enabled
« Reply #41 on: February 17, 2020, 03:07:50 PM »
Here is the example.config file.  Download it and save it in the same directory as exiftool.  It needs to be renamed to .ExifTool_config (dot at the front). If you're using windows, that can't be done on the desktop.  It either has to be done when save the file or through CMD.

One that is done, open it up in a text editor (not a word processor).  Go to the bottom of the file and locate this line
%Image::ExifTool::UserDefined::Options
You'll see several options set there.  After the RequestAll and before the );, add this new line
LargeFileSupport => 1,
Troubleshooting hints:
* When posting, include your OS, Exiftool version, and type of file you're processing (MP4, JPG, etc).
* Double all percent signs (%) in a Windows batch file.
* If your GPS coords are negative, make sure and set the GpsLatitudeRef and GpsLongitudeRef tags correctly.