Author Topic: How to remove ICC Profile -icc_profile:all= does not seem to work  (Read 9363 times)

c++

  • Jr. Member
  • **
  • Posts: 24
Hi,

I need to remove any ICC profile data from a set of images. (Yes I know what I am doing and why.)
I can't figure out how to do that "-icc_profile:all=" does not seem to work.

How can I remove all ICC profile data from an image?

Thanks a lot.

Phil Harvey

  • ExifTool Author
  • Administrator
  • ExifTool Freak
  • *****
  • Posts: 18370
    • ExifTool Home Page
Re: How to remove ICC Profile -icc_profile:all= does not seem to work
« Reply #1 on: March 06, 2012, 12:03:59 PM »
"-icc_profile:all=" does not seem to work.

Why do you say it doesn't work?  Does "exiftool -icc_profile FILE" return anything after you do this?

- Phil
...where DIR is the name of a directory/folder containing the images.  On Mac/Linux, use single quotes (') instead of double quotes (") around arguments containing a dollar sign ($).

c++

  • Jr. Member
  • **
  • Posts: 24
Re: How to remove ICC Profile -icc_profile:all= does not seem to work
« Reply #2 on: March 06, 2012, 12:13:52 PM »
No, actually it turns out that:

exiftool -icc_profile -b -w icc FILE.tiff

does not return a file either.

If I open the tiff in Photoshop however PS reports an embedded profile.
Not a missing profile but a specific embedded one.

Phil Harvey

  • ExifTool Author
  • Administrator
  • ExifTool Freak
  • *****
  • Posts: 18370
    • ExifTool Home Page
Re: How to remove ICC Profile -icc_profile:all= does not seem to work
« Reply #3 on: March 06, 2012, 12:34:15 PM »
If you send me the file I'll take a look.  My email is philharvey66 at gmail.com

- Phil
...where DIR is the name of a directory/folder containing the images.  On Mac/Linux, use single quotes (') instead of double quotes (") around arguments containing a dollar sign ($).

Phil Harvey

  • ExifTool Author
  • Administrator
  • ExifTool Freak
  • *****
  • Posts: 18370
    • ExifTool Home Page
Re: How to remove ICC Profile -icc_profile:all= does not seem to work
« Reply #4 on: March 07, 2012, 07:16:00 AM »
Thanks, I got the images.

I can assure you that there is no ICC_Profile in the image.

However, the ColorSpace tag is set to "sRGB", which defines the standard sRGB profile.

How do you display the profile in Photoshop, and what does it say it is?

- Phil
...where DIR is the name of a directory/folder containing the images.  On Mac/Linux, use single quotes (') instead of double quotes (") around arguments containing a dollar sign ($).

c++

  • Jr. Member
  • **
  • Posts: 24
Re: How to remove ICC Profile -icc_profile:all= does not seem to work
« Reply #5 on: March 07, 2012, 09:50:53 AM »
Thank you very much. I didn't think of that. PS did interpret the data to be sRGB.

It seems that if there is no actual profile embedded PS interprets the Colorspace property and treats the image as if there were an embedded profile. 
So I need to remove the Colorspace property, too. Adding "-all:Colorspace=" to what I'm doing solves my problem.


Stephen Marsh

  • Sr. Member
  • ****
  • Posts: 229
Re: How to remove ICC Profile -icc_profile:all= does not seem to work
« Reply #6 on: August 10, 2017, 07:38:10 PM »
I just stumbled over this old post, just in case it helps anybody…

Photoshop has a file handling preference to “ignore EXIF colour space” which if left unchecked, will treat any image with an EXIF Colourspace = 1 as sRGB (with a value of 0 being uncalibrated) or ExifIFD:ColorSpace='sRGB' in ExifTool as being tagged with the sRGB ICC profile. If this box is checked/on, the file will open up into Photoshop without an ICC profile being presented as embedded in the image.