Author Topic: Exiftool stops working in Windows 10 but does its job in GeoSetter  (Read 6021 times)

leahcimi

  • Jr. Member
  • **
  • Posts: 17
Re: Exiftool stops working in Windows 10 but does its job in GeoSetter
« Reply #15 on: November 23, 2015, 04:53:42 AM »
I had Geosetter already installed but removed it, did a thorough cleanup and renistalled. I still get the same problems: if I run EXIFTool in EXIFToolGUI, I simply get the 'EXIFTool has stopped working' error message.
If I run GeoSetter, I get numerous 'EXIFTool has stopped working' messages (looks like one per image in the selected folder) but them EXIF data shows up and GeoSetter appears to do its job despite the occasional extra 'EXIFTool has stopped working' message.
Very odd.
If it's any use, here is a copy of the WER file.
« Last Edit: November 23, 2015, 09:56:21 AM by leahcimi »

Gary

  • Full Member
  • ***
  • Posts: 48
Re: Exiftool stops working in Windows 10 but does its job in GeoSetter
« Reply #16 on: November 23, 2015, 12:01:10 PM »
That is odd, but it does seem to indicate that the issue is not the way you installed ExifTools. The independent installations fail in a similar way.
Since only the ExifTools instances seem to misbehave, it seems logical that ExifTool would be the root issue.

Before raising this directly with Phil. You probably should check the following. I'm sure he'd ask something similar.

On GeoSetter, did you go to the Help menu and use the "Check for Update" and "ExifTool" selections to make sure you were using the latest released version of GeoSetter and ExifTool.

I forgot if I asked you before. Have you recently gone into the Windows update screen and done a manual update? When I had issues, their tech told me that the automatic update doesn't get everything and a periodic manual update is needed. He seemed to be correct and that's what I now do before looking elsewhere.

Did you also get the recent large update to Window 10 in November? It fixed a lot of things for people. It was a pretty big update.

leahcimi

  • Jr. Member
  • **
  • Posts: 17
Re: Exiftool stops working in Windows 10 but does its job in GeoSetter
« Reply #17 on: November 23, 2015, 12:53:32 PM »
GeoSetter is using the latest EXIFTool 10.05 and, yes I have done the latest huge Windows update.

Gary

  • Full Member
  • ***
  • Posts: 48
Re: Exiftool stops working in Windows 10 but does its job in GeoSetter
« Reply #18 on: November 23, 2015, 03:06:03 PM »
Then, I guess you've done what you can.
I'd ask Phil what he thinks.

Phil Harvey

  • ExifTool Author
  • Administrator
  • ExifTool Freak
  • *****
  • Posts: 16667
    • ExifTool Home Page
Re: Exiftool stops working in Windows 10 but does its job in GeoSetter
« Reply #19 on: November 23, 2015, 05:19:11 PM »
Unfortunately I don't currently have access to a Windows 10 system, so I don't know what I can do to help with this problem.

- Phil
...where DIR is the name of a directory/folder containing the images.  On Mac/Linux, use single quotes (') instead of double quotes (") around arguments containing a dollar sign ($).