Error message while saving Exif changes - no changes saved

Started by HanSch, August 30, 2022, 04:15:10 PM

Previous topic - Next topic


Countless times I changed Exif info with ExifToolGUI without any problem. Mainly to change the focal length when a teleconverter was used, but not recognized by the camera. RAW files, jpg, no difference.
Now I can't save the changes anymore: Error creating file: IMGP3573.DNG_exiftool_tmp - IMGP3573.DNG.
I tried everything I can think of, but I can't get rid of the error. Files I changed in the past return the same error message. Maybe there is some Windows permission denied.
Anyone with a solution?


Check to make sure the _exiftool_tmp doesn't already exist and make sure there's still room on the drive.  And check the health of the drive to make sure it's not dying.
* Did you read FAQ #3 and use the command listed there?
* Please use the Code button for exiftool code/output.
* Please include your OS, Exiftool version, and type of file you're processing (MP4, JPG, etc).


Thank you for the response.
The problem is caused by the OS, if I try to remove some metadata using the Windows Explorer error code 0x88982F50 is returned, that can be found on the internet. But without a solid solution. Somehow the metadata are locked by the Windows MediaPlayer. Going back to the situation before my earliest available system restore point doesn't help.
As a turnaround I now copy the files that I need to edit to a removable disk, together with ExifTool GUI, and do the job on another computer. Cumbersome, but better than nothing.
Of course, a final solution is still very welcome.