Author Topic: EXIFToolGui516 Starts but then closes  (Read 3808 times)

GilExifUser

  • Newbie
  • *
  • Posts: 3
EXIFToolGui516 Starts but then closes
« on: January 14, 2019, 03:29:15 PM »
I've tried starting the programs many times.  On the last occasion, for the first time, an error was displayed.  It is the same error in another thread, not able to find exiftool.   I will close this thread, then.
Thanks.


Environment:
Windows 10 64 Bit
exiftool executable in /Windows directory
ExiftoolGui files in c:/ExiftoolGui
Files:
Workspace folder
Exiftoolgui.exe

When I double-click to start the program, a window opens up for a short time.  It appears that it is trying to set up. The headers in the window in which files are displayed flash and then the window disappears.

Anyone have this problem and found a solution?
Thanks
« Last Edit: January 14, 2019, 07:45:39 PM by GilExifUser »

rvdkrogt

  • Newbie
  • *
  • Posts: 9
Re: EXIFToolGui516 Starts but then closes
« Reply #1 on: January 15, 2019, 03:30:41 AM »
I had the same problem. The only solution I found was everytime removing the ini-file.

I made a batch file for removing the file before starting ExiftoolGui.

The batchfile is:
cd c:\[Program directory]\ExiftoolGui
del *.ini
ExifToolGUI.exe

This works for me.

Phil Harvey

  • ExifTool Author
  • Administrator
  • ExifTool Freak
  • *****
  • Posts: 16308
    • ExifTool Home Page
Re: EXIFToolGui516 Starts but then closes
« Reply #2 on: January 15, 2019, 07:16:15 AM »
Interesting.  The problem sounds like it could have to do with permissions writing the .ini file.  I wonder if running as administrator would help.

- Phil
...where DIR is the name of a directory/folder containing the images.  On Mac/Linux, use single quotes (') instead of double quotes (") around arguments containing a dollar sign ($).

rvdkrogt

  • Newbie
  • *
  • Posts: 9
Re: EXIFToolGui516 Starts but then closes
« Reply #3 on: January 16, 2019, 03:09:12 AM »
I tried running as administrator but it did't work.

Strontium

  • Newbie
  • *
  • Posts: 6
Re: EXIFToolGui516 Starts but then closes
« Reply #4 on: June 30, 2019, 08:44:33 AM »
The only solution I found was everytime removing the ini-file.

I always have the ini file open in Sublime text editor https://www.sublimetext.com/.

If ExifToolGUI don't want to open, i just change the DefaultDir to a reachable path, e.g.
Code: [Select]
DefaultDir=D:\Data\

sempervirentz

  • Newbie
  • *
  • Posts: 3
  • working in the stock photo industry
Re: EXIFToolGui516 Starts but then closes
« Reply #5 on: September 25, 2019, 09:46:53 AM »
In my case the program closes, if in the ini file StartMax is set to 1. When I set StartMax=0 (the default value) it works fine. But as I like to use the GUI full screen, I always have to reset this. Any solution to avoid this?

ajax

  • Newbie
  • *
  • Posts: 4
Re: EXIFToolGui516 Starts but then closes
« Reply #6 on: January 18, 2020, 03:12:54 PM »
I have ExifToolGUI installed on a thumb drive.  I can take it to different computers and it works fine until I get to a Windows 10 computer.  On Win10 it opens momentarily and then closes immediately.  The ini file has StartMax=0.  When I move the .ini file to a temporary location (i.e., get rid of it), then ExifToolGUI open but displays the dialogue message shown as ExifGUIerror1.png (attachment).  Then when "OK" is selected the program opens, and stays that way, until you select a directory in the file browser which results in ExifGUIerror2.png (attachment).

My Windows 7 computer just broke and given the status of Windows 7 it seems like it might be problematic to replace it with another Windows 7 computer.  However, I use ExifToolGUI enough I would consider doing just that.  I know ExifToolGUI has been stabilized but I'm thinking this is probably not a major problem.  Is there any hope to get it working on Win10? 

StarGeek

  • Global Moderator
  • ExifTool Freak
  • *****
  • Posts: 3476
Re: EXIFToolGui516 Starts but then closes
« Reply #7 on: January 18, 2020, 05:55:37 PM »
It works for some people but not for others.  Unfortunately, as mentioned in this sub-forums sticky post, the gui is no longer has support.

The most common problem seems to be anti-virus/windows defender interfering, but that's not necessarily a guarantee.
Troubleshooting hints:
* When posting, include your OS, Exiftool version, and type of file you're processing (MP4, JPG, etc).
* Double all percent signs (%) in a Windows batch file.
* If your GPS coords are negative, make sure and set the GpsLatitudeRef and GpsLongitudeRef tags correctly.

ajax

  • Newbie
  • *
  • Posts: 4
Re: EXIFToolGui516 Starts but then closes
« Reply #8 on: January 19, 2020, 10:26:29 AM »
Yes!  When I turn off Windows Defender it seems to work.  Not sure where that leaves me but it is very good to know that which is very helpful.  Many thanks!!!

StarGeek

  • Global Moderator
  • ExifTool Freak
  • *****
  • Posts: 3476
Re: EXIFToolGui516 Starts but then closes
« Reply #9 on: January 19, 2020, 11:04:06 AM »
I'd suggest trying to add an exception to Defender for both the GUI and Exiftool rather than keep it turned off.  See this page for instructions.
Troubleshooting hints:
* When posting, include your OS, Exiftool version, and type of file you're processing (MP4, JPG, etc).
* Double all percent signs (%) in a Windows batch file.
* If your GPS coords are negative, make sure and set the GpsLatitudeRef and GpsLongitudeRef tags correctly.

ajax

  • Newbie
  • *
  • Posts: 4
Re: EXIFToolGui516 Starts but then closes
« Reply #10 on: January 20, 2020, 05:34:52 PM »
When I said "it seems to work" that was based on an experiment which did succeed.  However, I did other things and it is back to the same kind of failure.  The first other thing was to boot a different instance of Win10 (i.e., my computers are setup to use multi-boot).  When I first tried ExifToolGUI it seemed to work without even bothering to disable Windows Defender.  Then I went back to the original instance of Win10 to see what would happen there.  It now fails and turning off Windows Defender was NO help this time.  It still failed.  Then I went back to the instance of Win10 where it had just worked and now it fails.  Note:  The ExifToolGUI/ExifTool are stored on the same thumb drive used in every case.

Conclusion, it works very seldom.  Certainly is very unreliable.

The first error indicates that ExifToolGUI cannot find ExifTool.  Is it possible that there is some difference in how Win10 finds executable files that could be the cause?  The ExifTool program is located in the same directory as ExifToolGUI.

Another bit of nuance is that I also use a program called XnViewMP which makes extensive use of ExifTool.  It appears to have ExifTool stored in one of its sub-directories but seems to never have any such problem.  Might there be some problem caused by using different instances of ExifTool.  I had run XnViewMP on the secondary instance of Win10 between the time that ExifToolGUI succeeded and when it failed.

StarGeek

  • Global Moderator
  • ExifTool Freak
  • *****
  • Posts: 3476
Re: EXIFToolGui516 Starts but then closes
« Reply #11 on: January 20, 2020, 07:07:08 PM »
Conclusion, it works very seldom.  Certainly is very unreliable.

That's pretty much my experience.  Sometimes it will work for a couple of files, but then it crashes.  When it works, it never works longer than 2-3 commands.

Quote
The first error indicates that ExifToolGUI cannot find ExifTool.  Is it possible that there is some difference in how Win10 finds executable files that could be the cause?  The ExifTool program is located in the same directory as ExifToolGUI.

Has it been properly renamed?

Quote
Might there be some problem caused by using different instances of ExifTool.  I had run XnViewMP on the secondary instance of Win10 between the time that ExifToolGUI succeeded and when it failed.

No.  IMatch5, for example, runs 4 instances of exiftool simultaneously at all times.  Even different versions extract to their separate folders when unpacked in the temp dir.

 
Troubleshooting hints:
* When posting, include your OS, Exiftool version, and type of file you're processing (MP4, JPG, etc).
* Double all percent signs (%) in a Windows batch file.
* If your GPS coords are negative, make sure and set the GpsLatitudeRef and GpsLongitudeRef tags correctly.

ajax

  • Newbie
  • *
  • Posts: 4
Re: EXIFToolGui516 Starts but then closes
« Reply #12 on: January 23, 2020, 07:27:49 PM »
Sorry for slow response.  I did post a question on Microsoft forums and received some feedback that calls for experimentation which takes time.  Will reply hear with anything that proves to be positive.  The on again off again nature of problem makes it difficult to know effectiveness of positive results.
Quote
Has it been properly renamed?
Having it installed on thumb drive means what I running on Win10 is no different from what works great on Win7.  Wouldn't that imply that the name is OK?  Wouldn't it always fail if name were a problem?

StarGeek

  • Global Moderator
  • ExifTool Freak
  • *****
  • Posts: 3476
Re: EXIFToolGui516 Starts but then closes
« Reply #13 on: January 23, 2020, 08:20:03 PM »
Wouldn't that imply that the name is OK?  Wouldn't it always fail if name were a problem?

Yeah, if it's working from a flash drive on Win7, then the name isn't the problem.
Troubleshooting hints:
* When posting, include your OS, Exiftool version, and type of file you're processing (MP4, JPG, etc).
* Double all percent signs (%) in a Windows batch file.
* If your GPS coords are negative, make sure and set the GpsLatitudeRef and GpsLongitudeRef tags correctly.

SharkyCA

  • Newbie
  • *
  • Posts: 2
Re: EXIFToolGui516 Starts but then closes
« Reply #14 on: February 19, 2020, 09:48:07 PM »
I've tried starting the programs many times.  On the last occasion, for the first time, an error was displayed.  It is the same error in another thread, not able to find exiftool.   I will close this thread, then.
Thanks.


Environment:
Windows 10 64 Bit
exiftool executable in /Windows directory
ExiftoolGui files in c:/ExiftoolGui
Files:
Workspace folder
Exiftoolgui.exe

When I double-click to start the program, a window opens up for a short time.  It appears that it is trying to set up. The headers in the window in which files are displayed flash and then the window disappears.

Anyone have this problem and found a solution?
Thanks

Interesting.  The problem sounds like it could have to do with permissions writing the .ini file.  I wonder if running as administrator would help.

- Phil

Hi All,

I have been gathering some info before posting to this thread. I have the Windows 10 Blues, every time they run an update something else on my laptop breaks!

I have had most of my success with getting "ExifTool & ExiftoolGui" running on my :
Windows 10
  Version   10.0.18363 Build 18363
  HP Laptop 8gig
By using the install tool mentioned in this post by Phil Harvey: https://exiftool.org/forum/index.php?topic=10315.0 which includes the "Install tool" created by Oliver Betz.

Although I still get an error if I try to "drag file to desktop icon" the ExiftoolGui still will sometimes crash!

Here is a copy of the crash log if any of you Programmer Types would care to investigate, hope it will help? ;D